Knowledge Base · Kategorie 18
ACME im Detail
Dieses Kapitel erklärt, wie TLSPilot Zertifikate von öffentlichen ACME-Providern bezieht, woher es weiss, wann sie zu erneuern sind, was ACME-Profile sind, wie CAA-Records im DNS einschränken, welche CA ausstellen darf, und wie die CA eine Challenge validiert. Für Ihr erstes Zertifikat brauchen Sie diese Details nicht, aber sie helfen Ihnen, die Einstellungen in Kapitel ACME-Zertifikat (AC) zu verstehen und die Ursache zu finden, wenn eine Validierung fehlschlägt.
Artikel in dieser Kategorie
- 18.1
So funktioniert ACME
ACME (Automatic Certificate Management Environment, RFC 8555) ist ein offenes Internetprotokoll.
- 18.2
ARI (ACME Renewal Information)
Mit ARI (ACME Renewal Information, RFC 9773) teilt die CA TLSPilot mit, wann ein Zertifikat erneuert werden soll.
- 18.3
ACME-Profile
Manche CAs bieten unter einem ACME-Directory mehrere Arten von Zertifikaten an, zum Beispiel mit unterschiedlicher Gültigkeit.
- 18.4
CAA-Records
Dieser Abschnitt ist DNS-Hintergrund. TLSPilot erstellt und prüft keine CAA-Records, aber ein unpassender CAA-Record führt dazu, dass die CA das Zertifikat verweigert, und TLSPilot zeigt dann den Fehler der CA.
- 18.5
Multi-Perspective Validation
Dieser Abschnitt ist Hintergrund. TLSPilot kann nicht ändern, wie die CA validiert, aber die Einstellungen Ihres DNS, Ihrer Firewall und Ihres Netzwerks entscheiden, ob die Validierung gelingt.
- 18.6
DNS-01
Bei DNS-01 weisen Sie die Kontrolle über einen Namen über seine öffentliche DNS-Zone nach (RFC 8555, Abschnitt 8.4).
- 18.7
DNS-01 Challenge Delegation (CNAME-Alias)
Bei der DNS-01 Challenge Delegation validiert die CA die Namen des Zertifikats über einen CNAME-Record, der in eine separate DNS-Zone zeigt, die Alias-Zone.
- 18.8
HTTP-01
Bei HTTP-01 weisen Sie die Kontrolle über einen Namen mit einer Datei auf dem Webserver nach, auf den der Name zeigt (RFC 8555, Abschnitt 8.3).
- 18.9
TLS-ALPN-01
Bei TLS-ALPN-01 weisen Sie die Kontrolle über einen Namen mit einem speziellen TLS-Handshake auf Port 443 nach (RFC 8737).